Browse source

Changelog

Query
From:
To:
Branch:
Path:
Message:
BugID:
User: +
Format:
: 11 checkins (+21/-12) by Henrik Grubbström (Grubba) <grubba@grubba.org> Lines added/removed recently

Friday 04 January 2019

2019-01-04 12:15:15 (3 years ago) by Henrik Grubbström (Grubba) <grubba@grubba.org>

Merge branch 'patches/ws390' into devel

* patches/ws390:
UserDB [LDAP] [Pike 7.8]: Fixed broken handling of %u%.

2019-01-04 11:37:31 (3 years ago) by Henrik Grubbström (Grubba) <grubba@grubba.org>

Merge branch 'patches/ws390' into 6.2

* patches/ws390:
UserDB [LDAP] [Pike 7.8]: Fixed broken handling of %u%.
Merge branch 'patches/ws390' into 6.1

* patches/ws390:
UserDB [LDAP] [Pike 7.8]: Fixed broken handling of %u%.
Merge branch 'patches/ws390' into 6.0

* patches/ws390:
UserDB [LDAP] [Pike 7.8]: Fixed broken handling of %u%.
Merge branch 'patches/ws390' into 5.5

* patches/ws390:
UserDB [LDAP] [Pike 7.8]: Fixed broken handling of %u%.

2019-01-04 11:34:52 (3 years ago) by Henrik Grubbström (Grubba) <grubba@grubba.org>

Merge branch 'patches/ws390' into 5.4

* patches/ws390:
UserDB [LDAP] [Pike 7.8]: Fixed broken handling of %u%.
Merge branch 'patches/ws390' into 5.2

* patches/ws390:
UserDB [LDAP] [Pike 7.8]: Fixed broken handling of %u%.
Merge branch 'patches/ws390' into 5.1

* patches/ws390:
UserDB [LDAP] [Pike 7.8]: Fixed broken handling of %u%.

2019-01-04 11:32:28 (3 years ago) by Henrik Grubbström (Grubba) <grubba@grubba.org>

UserDB [LDAP] [Pike 7.8]: Fixed broken handling of %u%.

Since Pike 7.7.14 all URI-escapes in LDAP-URLs are decoded.
This broke use of the magic marker '%u%' as it was interpreted
as a Unicode-escape. We now force the marker to be escaped
properly before parsing the LDAP-URL.

Also some related code-cleanup.

Fixes [WS-390].

[permalink]

Bugs? Suggestions?