Branch: Tag:

2015-12-14

2015-12-14 11:42:30 by Henrik Grubbström (Grubba) <grubba@grubba.org>

SSL: Enable the cipher strength selector in recent Pike 7.8.

Fixes issue with RC4 suites being available by default.

2310: Inside #if constant(SSL.ServerConnection)
   });    }    ctx->preferred_suites = suites; + #elif !constant(SSL.Constants.preferred_rsa_suites) +  int bits = query("ssl_key_bits"); +  ctx->preferred_suites = ctx->get_suites(bits);   #else   #ifndef ALLOW_WEAK_SSL    // Filter weak and really weak cipher suites.