Branch: Tag:

2008-06-24

2008-06-24 16:19:52 by Martin Stjernholm <mast@lysator.liu.se>

Changed __roxen_version__ to roxen_ver and __roxen_build__ to roxen_build to
work with pike 7.7.

Note compat issues, not least in build systems which might extract these.

Rev: server/base_server/configuration.pike:1.652
Rev: server/base_server/roxen.pike:1.977
Rev: server/base_server/roxenloader.pike:1.395
Rev: server/bin/functions:1.18
Rev: server/bin/mk_wxs.pike:1.16
Rev: server/config_interface/actions/change_version.pike:1.14
Rev: server/etc/include/version.h:1.978
Rev: server/etc/modules/Roxen.pmod:1.243
Rev: server/modules/configuration/config_filesystem.pike:1.116
Rev: server/modules/logging/roxen_network.pike:1.15
Rev: server/protocols/ftp.pike:2.123
Rev: server/tools/ntroxen/startdll/roxen.cpp:1.18

1:   /* -  * $Id: mk_wxs.pike,v 1.15 2004/11/24 09:45:02 grubba Exp $ +  * $Id: mk_wxs.pike,v 1.16 2008/06/24 16:19:52 mast Exp $    *    * Make a Windows Installer XML Source file (wxs) suitable    * for a Roxen installer.
10:   import Standards.XML.Wix;      #ifdef ROXEN_VERSION - constant __roxen_version__ = "4.0"; - constant __roxen_build__ = "0"; + constant roxen_ver = "5.0"; + constant roxen_build = "0";   #else   #include "../etc/include/version.h"   #endif
19:   int main(int argc, array(string) argv)   {    string base_guid = "e0eb949e-2d84-11d9-8482-77582478aab0"; // WebServer. -  string version_str = __roxen_version__+"."+__roxen_build__; +  string version_str = roxen_ver+"."+roxen_build;    string title = "Roxen Webserver";    string manufacturer = "Roxen Internet Software";    string pike_module = "Pike_module.msm";
39:    if (stringp(opt[1])) {    version_str = opt[1];    } else { -  werror("$Id: mk_wxs.pike,v 1.15 2004/11/24 09:45:02 grubba Exp $\n"); +  werror("$Id: mk_wxs.pike,v 1.16 2008/06/24 16:19:52 mast Exp $\n");    exit(0);    }    break;