Branch: Tag:

2015-06-17

2015-06-17 13:13:36 by Henrik Grubbström (Grubba) <grubba@grubba.org>

Pike 8.0: SSL.sslfile has been obsoleted by SSL.File.

Update to the new API, and remove some old-style code.

Improved compatibility with Pike 8.1.

2086:    protocol, lower_case( protocol ))+"\n";    protocol = lower_case( protocol );    } - #if constant(SSL.sslfile) + #if constant(SSL.File)    // All is A-OK   #else    if( (protocol == "https" || protocol == "ftps") )