Branch: Tag:

2014-05-02

2014-05-02 13:23:21 by Henrik Grubbström (Grubba) <grubba@grubba.org>

Compat: Added 7.8::SSL.

This is based on the last version of SSL on the 8.0 branch
that was still compatible with Pike 7.8 (ie before the PEM
API changes).

Intended use is Crypto API compatibility testing, though it
is probably more competent than the current Pike 7.8 SSL.

1: - #pike 8.0 - #require constant(SSL.Cipher) + #pike 7.8    -  + #if constant(SSL.Cipher.CipherAlgorithm) +    //! Interface similar to @[Stdio.Port].      //!   inherit Stdio.Port : socket;      //! - inherit SSL.context; + inherit .context;      //!   inherit ADT.Queue : accept_queue;
173:    accept_queue::create();    set_id(this);   } +  + #else // constant(SSL.Cipher.CipherAlgorithm) + constant this_program_does_not_exist = 1; + #endif