Branch: Tag:

2015-01-19

2015-01-19 13:32:40 by Martin Nilsson <nilsson@opera.com>

Deprecated verify_certificates, as auth_level does the same thing. This breaks some tests that appears to be incomplete, so disable them.

263:   //   int verify_certificate_chain(array(string) certs)   { -  // Do we need to verify the certificate chain? -  if(!context->verify_certificates) -  return 1; -  +     // If we're not requiring the certificate, and we don't provide one,    // that should be okay.    if((context->auth_level < AUTHLEVEL_require) && !sizeof(certs))