Branch: Tag:

2015-12-06

2015-12-06 13:11:51 by Henrik Grubbström (Grubba) <grubba@grubba.org>

SSL.Context: Deprecated variable require_trust.

Setting of this variable is now equivalent to setting the
auth_level to AUTHLEVEL_require.

310:    catch {    result = Standards.X509.verify_certificate_chain(certs,    context->trusted_issuers_cache, -  context->require_trust); +  context->auth_level >= AUTHLEVEL_require);    };       if (session->server_name && sizeof([array](result->certificates || ({})))) {