Branch: Tag:

2014-11-13

2014-11-13 20:10:35 by Arne Goedeke <el@laramies.com>

rename aligned_alloc to xalloc_aligned

C11 defines aligned_alloc. This can lead to all kinds of confusion, so
lets rename our internal function.

74:    size_t n = l.offset + l.block_size + l.doffset;    struct ba_page * p;    if (l.alignment) { -  p = aligned_alloc(n, l.alignment); +  p = xalloc_aligned(n, l.alignment);    } else {   #ifdef DEBUG_MALLOC    /* In debug malloc mode, calling xalloc from the block alloc may result