Branch: Tag:

2008-06-16

2008-06-16 21:46:35 by Martin Stjernholm <mast@lysator.liu.se>

Changed do_really_free_pike_string to a much more descriptive name. Viva ABI
incompatibility! ;)

Rev: src/builtin_functions.c:1.671
Rev: src/modules/files/file.c:1.391
Rev: src/stralloc.c:1.220
Rev: src/stralloc.h:1.106

2:   || This file is part of Pike. For copyright information see COPYRIGHT.   || Pike is distributed under GPL, LGPL and MPL. See the file COPYING   || for more information. - || $Id: builtin_functions.c,v 1.670 2008/06/01 11:19:45 grubba Exp $ + || $Id: builtin_functions.c,v 1.671 2008/06/16 21:46:35 mast Exp $   */      #include "global.h"
701:    }       /* Discard the too narrow string and use the new one instead. */ -  do_really_free_pike_string(ret); +  do_free_unlinked_pike_string(ret);    ret = wret;    break;    }