Branch: Tag:

2006-08-12

2006-08-12 02:57:55 by Martin Stjernholm <mast@lysator.liu.se>

Charset and unicode support, mk2. MySQL server 4.1 or later is required to
make use of this, but the client lib can still be from the darker stone age.

Warning: Not tested with a pre-4.1 server.

Rev: lib/modules/Sql.pmod/mysql.pike:1.25
Rev: src/modules/Mysql/configure.in:1.51
Rev: src/modules/Mysql/mysql.c:1.98
Rev: src/modules/Mysql/precompiled_mysql.h:1.18

1:   # - # $Id: configure.in,v 1.50 2006/07/04 20:45:27 mast Exp $ + # $Id: configure.in,v 1.51 2006/08/12 02:57:55 mast Exp $   #   # Configure script for the mysql-module   #
371:    PIKE_CHECK_MYSQL_FUNC(mysql_real_query)    PIKE_CHECK_MYSQL_FUNC(mysql_fetch_lengths)    PIKE_CHECK_MYSQL_FUNC(mysql_options) +  PIKE_CHECK_MYSQL_FUNC(mysql_set_character_set)       AC_CHECK_LIB(mysqlclient, mysql_ssl_set, [    AC_DEFINE(HAVE_MYSQL_SSL)