Branch: Tag:

2014-11-13

2014-11-13 20:10:12 by Arne Goedeke <el@laramies.com>

rename aligned_alloc to xalloc_aligned

C11 defines aligned_alloc. This can lead to all kinds of confusion, so
lets rename our internal function.

233:   PMOD_EXPORT void debug_xfree(void *mem);   PMOD_EXPORT void *debug_xrealloc(void *m, size_t s) MALLOC_FUNCTION;   PMOD_EXPORT void *debug_xcalloc(size_t n, size_t s) MALLOC_FUNCTION; - PMOD_EXPORT void *aligned_alloc(size_t size, size_t alignment) MALLOC_FUNCTION; + PMOD_EXPORT void *xalloc_aligned(size_t size, size_t alignment) MALLOC_FUNCTION;      #define PIKE_ALIGNTO(x, a) (((x) + (a)-1) & ~((a)-1))