Branch: Tag:

2013-11-27

2013-11-27 09:01:04 by Arne Goedeke <el@laramies.com>

Crypto: compatibility with old nettle versions

nettle before 2.1 did not have sha224

627:   #cmod_undef PIKE_NAME   #cmod_undef NETTLE_NAME    + #ifdef HAVE_NETTLE_SHA224_INIT +    #cmod_define PIKE_NAME SHA224   #cmod_define NETTLE_NAME sha224   #cmod_include "hash.H"   #cmod_undef PIKE_NAME   #cmod_undef NETTLE_NAME    -  + #endif +    #cmod_define PIKE_NAME SHA256   #cmod_define NETTLE_NAME sha256   #cmod_include "hash.H"