Roxen.git / server / etc / modules / Variable.pmod / module.pmod

version» Context lines:

Roxen.git/server/etc/modules/Variable.pmod/module.pmod:1577:    // in this case since that will cause a bogus warning.    return 0;    to = mod;    }    return ::set(to);    }       RoxenModule|array(RoxenModule) query()    {    array(RoxenModule)|RoxenModule res = changed_values[_id]; -  if (!res) { +  if (!res || (multiselect && has_value(res, 0))) {    if (module_id) {    // The module might have been reloaded.    // Try locating it again.    if (multiselect) {    res = map(module_id, transform_from_form);    } else {    res = transform_from_form(module_id);    }    } else {    res = default_value();