Roxen.git / server / etc / modules / Variable.pmod / module.pmod

version» Context lines:

Roxen.git/server/etc/modules/Variable.pmod/module.pmod:1: - // $Id: module.pmod,v 1.38 2000/11/27 10:31:01 per Exp $ + // $Id: module.pmod,v 1.39 2000/11/27 11:44:34 nilsson Exp $      #include <module.h>   #include <roxen.h>      // Locale macros   //<locale-token project="roxen_config"> LOCALE </locale-token>      #define LOCALE(X,Y) \    ([string](mixed)Locale.translate("roxen_config",roxenp()->locale->get(),X,Y))   
Roxen.git/server/etc/modules/Variable.pmod/module.pmod:499:    //! 0 (the default), the range check is removed.    {    _max = maximum;    _min = minimum;    }       array(string|int) verify_set( mixed new_value )    {    string warn;    if(!intp( new_value ) ) -  return ({ sprintf(LOCALE(0,"%O is not an integer"),new_value), +  return ({ sprintf(LOCALE(152,"%O is not an integer"),new_value),    query() });    if( new_value > _max && _max > _min )    {    warn = sprintf(LOCALE(328,"Value is bigger than %s, adjusted"),    (string)_max );    new_value = _max;    }    else if( new_value < _min && _min < _max)    {    warn = sprintf(LOCALE(329,"Value is less than %s, adjusted"),