Roxen.git / server / modules / filesystems / filesystem.pike

version» Context lines:

Roxen.git/server/modules/filesystems/filesystem.pike:591:   {    if(f[0]=='.' && !dotfiles) return 0;    if(!tilde && Roxen.backup_extension(f)) return 0;    return 1;   }      array(string) list_lock_files() {    return query("nobrowse");   }    - protected mapping(string:mixed)|int(0..1) write_access(string path, + protected variant mapping(string:mixed)|int(0..1) write_access(string path,    int(0..1) recursive,    RequestID id)   {    SIMPLE_TRACE_ENTER(this, "write_access(%O, %O, %O)\n", path, recursive, id);    if(query("check_auth") && (!id->conf->authenticate( id ) ) ) {    SIMPLE_TRACE_LEAVE("%s: Authentication required.", id->method);    // FIXME: Sane realm.    // FIXME: Recursion and htaccess?    return    Roxen.http_auth_required("foo",