Roxen.git / server / modules / filesystems / tarfs.pike

version» Context lines:

Roxen.git/server/modules/filesystems/tarfs.pike:1:   inherit "module";    - constant cvs_version= "$Id: tarfs.pike,v 1.2 2000/09/14 13:51:13 per Exp $"; + constant cvs_version= "$Id: tarfs.pike,v 1.3 2000/09/23 02:05:51 per Exp $";      // The Filesystem.Tar module is not threadsafe.   constant thread_safe=0;      #include <module.h>      constant module_type = MODULE_LOCATION;   constant module_name = "Tarfile system";   constant module_doc =   ("This is a file system module that makes it possible to mount a "
Roxen.git/server/modules/filesystems/tarfs.pike:15:    "tar-files are not supported");   constant module_unique = 0;      void create()   {    defvar( "mountpoint", "/standard/docs/",    "Mount point", TYPE_LOCATION|VAR_INITIAL,    "Where the module will be mounted in the site's virtual file "    "system." );    -  defvar("tarfile", "docs.tar", "Tar file and root path", TYPE_FILE|VAR_INITIAL, +  defvar("tarfile", "config_interface/docs.tar", +  "Tar file and root path", TYPE_FILE|VAR_INITIAL,    "The tarfile, and an optional root path (syntax: /tar/file.tar:/"    "root/dir/)" );   }      string mp, error_msg;      // Filesystem.Tar (does not work with 7.0)   object tar;      void start()