pike.git / lib / 7.8 / modules / SSL.pmod / connection.pike

version» Context lines:

pike.git/lib/7.8/modules/SSL.pmod/connection.pike:53:    void|ProtocolVersion max_version)   {    alert::create();    urgent::create();    application::create();    current_read_state = SSL.state(this);    current_write_state = SSL.state(this);    handshake::create(is_server, ctx, min_version, max_version);   }    - #if 0 - protected void destroy() - { -  werror("Connection destructed:\n%s\n", describe_backtrace(backtrace())); - } - #endif /* 0 */ -  +    //! Called with alert object, sequence number of bad packet,   //! and raw data as arguments, if a bad packet is received.   //!   //! Can be used to support a fallback redirect https->http.   void set_alert_callback(function(object,int|object,string:void) callback)   {    alert_callback = callback;   }      //! Low-level receive handler. Returns a packet, an alert, or zero if