pike.git / lib / master.pike.in

version» Context lines:

pike.git/lib/master.pike.in:1:   // -*- Pike -*-   //   // Master Control Program for Pike.   //   // This file is part of Pike. For copyright information see COPYRIGHT.   // Pike is distributed under GPL, LGPL and MPL. See the file COPYING   // for more information.   // - // $Id: master.pike.in,v 1.339 2004/03/24 10:10:50 anders Exp $ + // $Id: master.pike.in,v 1.340 2004/04/11 15:56:26 grubba Exp $      #pike __REAL_VERSION__   //#pragma strict_types      // Some programs destroys character pairs beginning with the currency   // symbol when running in chinese locale.   #if "ยค/" != "\244/"   #error "master.pike.in is corrupted."   #endif   
pike.git/lib/master.pike.in:44:   //! This constant contains the maximum length of a function entry in a   //! backtrace. Defaults to 200 if no BT_MAX_STRING_LEN define has been   //! given.      // Enables the out of date warning in low_findprog().   #ifndef OUT_OF_DATE_WARNING   #define OUT_OF_DATE_WARNING 1   #endif /* OUT_OF_DATE_WARNING */   constant out_of_date_warning = OUT_OF_DATE_WARNING;    + // FIXME: PATH_SEPARATOR and UPDIR should probably be exported, + // or at least some functions that use them should be. + // cf Tools.Shoot.runpike. + // /grubba 2004-04-11   #if defined(__NT__) || defined(__amigaos__)   #define PATH_SEPARATOR ";"   #else   #define PATH_SEPARATOR ":"   #endif      #ifdef __amigaos__   #define UPDIR "/"   #else   #define UPDIR "../"