pike.git / lib / master.pike.in

version» Context lines:

pike.git/lib/master.pike.in:1:   // -*- Pike -*-   //   // Master Control Program for Pike.   //   // This file is part of Pike. For copyright information see COPYRIGHT.   // Pike is distributed under GPL, LGPL and MPL. See the file COPYING   // for more information.   // - // $Id: master.pike.in,v 1.434 2008/06/05 14:58:28 mast Exp $ + // $Id: master.pike.in,v 1.435 2008/06/05 15:08:10 mast Exp $      #pike __REAL_VERSION__   //#pragma strict_types      // Some programs destroys character pairs beginning with the currency   // symbol when running in chinese locale.   #if "ยค/" != "\244/"   #error "master.pike.in is corrupted."   #endif   
pike.git/lib/master.pike.in:1878:    // for use with embedded interpreters    // add path for architecture-dependant files    add_include_path(__embedded_resource_directory + "/lib/include");    add_module_path(__embedded_resource_directory + "/lib/modules");    add_module_path(__embedded_resource_directory + "/" + replace(uname()->machine, " ", "_") + "/modules");      #endif       system_module_path=pike_module_path;    if (master() && master() != this_object() && -  (compat_major < 7 || (compat_major == 7 && compat_minor <= 6)) { +  (compat_major < 7 || (compat_major == 7 && compat_minor <= 6))) {    // getenv() and putenv() will get confused if we don't do this.    // This is only for pike <= 7.6 compat.    if (mapping e = master()->environment) environment = e;    }   }         //! This function is called whenever a inherit is called for.   //! It is supposed to return the program to inherit.   //! The first argument is the argument given to inherit, and the second