pike.git / lib / modules / GTK.pmod

version» Context lines:

pike.git/lib/modules/GTK.pmod:1:   #pike __REAL_VERSION__      //! GTK wrapper module.   //! - //! This is a convenience module that is identical to either - //! either the @[GTK2] or the @[GTK1] module depending on - //! which (if any) of them is available. + //! This is a convenience module that is identical to the latest + //! supported GTK versionm, if available. Currently only @[GTK2] is + //! possible.   //!   //! @seealso - //! @[GTK1], @[GTK2] + //! @[GTK2]      #if constant(GTK2.Widget)   //!   inherit GTK2; - #elif constant(GTK1.Widget) - //! - inherit GTK1; +    #else   constant module_value = UNDEFINED;   #endif         Newline at end of file added.