pike.git / lib / modules / Parser.pmod / Pike.pmod

version» Context lines:

pike.git/lib/modules/Parser.pmod/Pike.pmod:1:   //   // This file needs to support old pikes that e.g. don't understand   // "#pike". Some of them fail when they see an unknown cpp directive.   //   // #pike __REAL_VERSION__   // - // $Id: Pike.pmod,v 1.31 2003/03/13 22:05:36 nilsson Exp $ + // $Id: Pike.pmod,v 1.32 2003/06/17 23:09:31 mast Exp $    - //! This module parses and tokanizes Pike source code. + //! This module parses and tokenizes Pike source code.      inherit "C.pmod";      #define UNKNOWN_TOKEN \    error("Unknown pike token: %O\n", data[pos..pos+20])      static mapping(string : int) backquoteops =   ([ "/":1, "/=":2,    "%":1, "%=":2,    "*":1, "*=":2,