pike.git / lib / modules / Parser.pmod / Pike.pmod

version» Context lines:

pike.git/lib/modules/Parser.pmod/Pike.pmod:1:   //   // This file needs to support old pikes that e.g. don't understand   // "#pike". Some of them fail when they see an unknown cpp directive.   //   // #pike __REAL_VERSION__   // - // $Id$ +       //! This module parses and tokenizes Pike source code.      inherit "C.pmod";      array(string) low_split(string data, void|mapping state)   {    if(state && state->remains)    data = m_delete(state, "remains") + data;    array ret;