pike.git / lib / modules / Protocols.pmod / HTTP.pmod / module.pmod

version» Context lines:

pike.git/lib/modules/Protocols.pmod/HTTP.pmod/module.pmod:139:    con = .Query();      #if constant(SSL.sslfile)    if(url->scheme!="http" && url->scheme!="https")    error("Can't handle %O or any other protocols than HTTP or HTTPS.\n",    url->scheme);       con->https = (url->scheme=="https")? 1 : 0;   #else    if(url->scheme!="http") -  error("Can't handle %O or any other protocol than HTTP.\n", +  error("Can't handle %O or any other protocol than HTTP " +  "(HTTPS requires Nettle support).\n",    url->scheme);   #endif       if(!request_headers)    request_headers = ([]);    mapping default_headers = ([    "user-agent" : "Mozilla/5.0 (compatible; MSIE 6.0; Pike HTTP client)"    " Pike/" + __REAL_MAJOR__ + "." + __REAL_MINOR__ + "." + __REAL_BUILD__,    "host" : url->host +    (url->port!=(url->scheme=="https"?443:80)?":"+url->port:"")]);