pike.git / lib / modules / SSL.pmod / Connection.pike

version» Context lines:

pike.git/lib/modules/SSL.pmod/Connection.pike:735:   //!   //! @param level   //! Alert level; either @[ALERT_warning] or @[ALERT_fatal].   //!   //! @param description   //! Alert description code; one of   //! @expr{indices(SSL.Constants.ALERT_descriptions)@}.   //!   //! @returns   //! @int - //! @elem value -1 + //! @value -1   //! A Fatal error occurred and processing should stop. - //! @elem value 0 + //! @value 0   //! Processing can continue. - //! @elem value 1 + //! @value 1   //! Connection should close.   //! @endint   int(-1..1) handle_alert(int level, int description)   {    COND_FATAL(!(ALERT_levels[level] && ALERT_descriptions[description]),    ALERT_unexpected_message, "Invalid alert\n");       // Consider all deprecated alerts as fatals.    COND_FATAL((ALERT_deprecated[description] &&    ALERT_deprecated[description] < version),