pike.git / lib / modules / SSL.pmod / Connection.pike

version» Context lines:

pike.git/lib/modules/SSL.pmod/Connection.pike:151:   string(8bit) hash_messages(string(8bit) sender, int|void len)   {    if(version == PROTOCOL_SSL_3_0) {    string(8bit) data = (string(8bit))handshake_messages + sender;    return .Cipher.MACmd5(session->master_secret)->hash(data) +    .Cipher.MACsha(session->master_secret)->hash(data);    }    else if(version <= PROTOCOL_TLS_1_1) {    return session->cipher_spec->prf(session->master_secret, sender,    Crypto.MD5.hash(handshake_messages)+ -  Crypto.SHA1.hash(handshake_messages), 12); +  Crypto.SHA1.hash(handshake_messages), +  len || 12);    }    return session->cipher_spec->prf(session->master_secret, sender,    session->cipher_spec->hash    ->hash(handshake_messages),    len || 12);   }      Packet certificate_packet(array(string(8bit)) certificates)   {    return handshake_packet(HANDSHAKE_certificate,