pike.git / lib / modules / SSL.pmod / Context.pike

version» Context lines:

pike.git/lib/modules/SSL.pmod/Context.pike:705: Inside #if constant(Crypto.ECC.Curve) && constant(Crypto.AES.GCM) && constant(Crypto.SHA384)
  //!   //! @note   //! Note also that for Suite B server operation compliant certificates   //! need to be added with @[add_cert()].   //!   //! @seealso   //! @[get_suites()]   void configure_suite_b(int(128..)|void min_keylength,    int(0..)|void strictness_level)   { +  if( !min_keylength ) min_keylength = 256;    if (min_keylength!=256)    error("Only keylength 256 supported.\n");       preferred_suites = ({    TLS_ecdhe_ecdsa_with_aes_256_gcm_sha384,    });       supported_versions = ({ PROTOCOL_TLS_1_2 });       if (strictness_level < 2) {