pike.git / lib / modules / SSL.pmod / Context.pike

version» Context lines:

pike.git/lib/modules/SSL.pmod/Context.pike:1006:       if (compat_rsa && certs) {    foreach(certs, array(string(8bit)) chain) {    catch {    add_cert(compat_rsa, chain);    };    }    }   }    - //! A mapping containing certificate chains for use by SNI (Server - //! Name Indication). Each entry should consist of a key indicating - //! the server hostname and the value containing the certificate chain - //! for that hostname. - //! - //! @deprecated add_cert - //! - //! @seealso - //! @[add_cert()] - __deprecated__ void `sni_certificates=(mapping(string:array(string(8bit))) sni) - { -  error("The old SNI API is not supported anymore.\n"); - } -  - __deprecated__ mapping(string:array(string(8bit))) `sni_certificates() - { -  return ([]); - } -  +    //! Compatibility.   //! @deprecated find_cert   __deprecated__ Crypto.DSA `dsa()   {    return UNDEFINED;   }      //! Compatibility.   //! @deprecated add_cert   __deprecated__ void `dsa=(Crypto.DSA k)