pike.git / lib / modules / SSL.pmod / Context.pike

version» Context lines:

pike.git/lib/modules/SSL.pmod/Context.pike:82:   //! @note   //! Not all alerts are fatal, and some (eg @[ALERT_close_notify]) are used   //! during normal operation.   Alert alert_factory(object con,    int(1..2) level, int(8bit) description,    ProtocolVersion version, string|void message)   {    return Alert(level, description, version, message);   }    - //! Should an SSL client include the Server Name extension? - //! - //! If so, then client_server_names should specify the values to send. - int client_use_sni = 0; -  - //! Host names to send to the server when using the Server Name - //! extension. - array(string(8bit)) client_server_names = ({}); -  +    //! Policy for client authentication. One of   //! @[SSL.Constants.AUTHLEVEL_none], @[SSL.Constants.AUTHLEVEL_ask]   //! and @[SSL.Constants.AUTHLEVEL_require].   int auth_level;      //! Array of authorities that are accepted for client certificates.   //! The server will only accept connections from clients whose   //! certificate is signed by one of these authorities. The string is a   //! DER-encoded certificate, which typically must be decoded using   //! @[MIME.decode_base64] or @[Standards.PEM.Messages] first.