pike.git / lib / modules / SSL.pmod / Context.pike

version» Context lines:

pike.git/lib/modules/SSL.pmod/Context.pike:871:    if (s->identity)    m_delete (session_cache, s->identity);    /* There's no need to remove the id from the active_sessions queue */   }         //   // --- Compat code below   //    - array(CertificatePair) `cert_pairs() - { -  return [array(CertificatePair)]Array.uniq([array]Array.sum(values(cert_chains_issuer))); - } -  - void `cert_pairs=(array(CertificatePair) list) - { -  cert_chains_issuer = ([]); -  cert_chains_domain = ([]); -  foreach(list, CertificatePair cp) -  add_cert(cp); - } -  - __deprecated__ array(CertificatePair) -  find_cert(array(string(8bit))|void sni_or_issuer, -  int(0..1)|void is_issuer) - { -  if( is_issuer ) -  return find_cert_issuer(sni_or_issuer); -  return find_cert_domain(sni_or_issuer && sni_or_issuer[0]); - } -  +    protected Crypto.RSA compat_rsa;   protected array(string(8bit)) compat_certificates;      //! The servers default private RSA key.   //!   //! Compatibility, don't use.   //!   //! @deprecated find_cert   //!   //! @seealso