pike.git / lib / modules / SSL.pmod / Session.pike

version» Context lines:

pike.git/lib/modules/SSL.pmod/Session.pike:397:   //!   //! @param version   //! The SSL protocol version to use.   //!   //! @param signature_algorithms   //! The set of signature algorithms tuples that the client claims to   //! support.   //!   //! @param max_hash_size   //! - int set_cipher_suite(int suite, ProtocolVersion|int version, + int set_cipher_suite(int suite, ProtocolVersion version,    array(array(int)) signature_algorithms,    int max_hash_size)   {    this_program::version = version;       array res = Cipher.lookup(suite, version, signature_algorithms,    truncated_hmac?512:max_hash_size);    if (!res) return 0;    cipher_suite = suite;    ke_method = [int]res[0];