pike.git / lib / modules / Sql.pmod / pgsql.pike

version» Context lines:

pike.git/lib/modules/Sql.pmod/pgsql.pike:170:   //! @value "force_ssl"   //! If the database supports and allows SSL connections, the session   //! will be SSL encrypted, if not, the connection will abort   //! @value "bool_results_as_text"   //! Make boolean values retrieved from the database backward compatible   //! with the old Postgres driver which returned all values as text.   //! When off, boolean values are represented by 0 and 1, when set,   //! boolean values are represented by "f" and "t".   //! @value "all_results_as_text"   //! Make all values backward compatible with the old Postgres driver - //! which returned all values as text. Implies boolresults_as_text. + //! which returned all values as text. Implies bool_results_as_text.   //! @value "client_encoding"   //! Character encoding for the client side, it defaults to use   //! database encoding, e.g.: "SQL_ASCII"   //! @value "standard_conforming_strings"   //! When on, backslashes in strings must not be escaped any longer,   //! @[quote] automatically adjusts quoting strategy accordingly   //! @value "escape_string_warning"   //! When on, a warning is issued if a backslash (\) appears in an   //! ordinary string literal and @[standard_conforming_strings] is off,   //! defaults to on