pike.git / lib / modules / Sql.pmod / pgsqls.pike

version» Context lines:

pike.git/lib/modules/Sql.pmod/pgsqls.pike:10:   //! @seealso   //! @[Sql.pgsql], @[Sql.Sql]      #pike __REAL_VERSION__      inherit Sql.pgsql;      protected void create(void|string _host, void|string _db,    void|string _user, void|string _pass, void|mapping(string:mixed) _options) {    string pass; -  pass = _pass; _pass = "CENSORED"; String.secure(pass); +  pass = _pass; _pass = "CENSORED"; +  if(pass) +  String.secure(pass);    if(!_options)    _options = ([]);       _options->use_ssl=1;       ::create(_host, _db, _user, pass, _options);   }