pike.git / lib / modules / Standards.pmod / X509.pmod

version» Context lines:

pike.git/lib/modules/Standards.pmod/X509.pmod:1632:   //! what it can and can not be used for.   //!   //! Returns a mapping with the following contents, depending   //! on the verification of the certificate chain:   //!   //! @mapping   //! @member int "error_code"   //! Error describing type of verification failures, if   //! verification failed. May be one of the following, OR:ed   //! together: @[CERT_TOO_NEW], @[CERT_TOO_OLD], - //! @[CERT_ROOT_UNTRUSTED], @[CERT_BAD_SIGNATURE], @[CERT_INVALID] - //! or @[CERT_CHAIN_BROKEN]. + //! @[CERT_ROOT_UNTRUSTED], @[CERT_BAD_SIGNATURE], + //! @[CERT_INVALID], @[CERT_CHAIN_BROKEN], @[CERT_UNAUTHORIZED_CA] + //! or @[CERT_EXCEEDED_PATH_LENGTH].   //! @member int "error_cert"   //! Index number of the certificate that caused the verification failure.   //! @member int(0..1) "self_signed"   //! Non-zero if the certificate is self-signed.   //! @member int(0..1) "verified"   //! Non-zero if the certificate is verified.   //! @member Standards.ASN1.Sequence "authority"   //! The authority RDN that verified the chain.   //! @member Standards.ASN1.Sequence "cn"   //! The common name RDN of the leaf certificate.