pike.git / lib / modules / Val.pmod

version» Context lines:

pike.git/lib/modules/Val.pmod:1: + #pike __REAL_VERSION__      //! This module contains special values used by various modules, e.g.   //! a null value used both by @[Sql] and @[Standards.JSON].   //!   //! In many ways these values should be considered constant, but it is   //! possible for a program to replace them with extended versions,   //! provided they don't break the behavior of the base classes defined   //! here. Since there is no good mechanism to handle such extending in   //! several steps, pike libraries should preferably ensure that the   //! base classes defined here provide required functionality directly.