pike.git / src / cpp.cmod

version» Context lines:

pike.git/src/cpp.cmod:772:    *! This tells the compiler which version of Pike it should    *! attempt to emulate from this point on in the current    *! compilation unit.    *!    *! This is typically used to "quick-fix" old code to work    *! with more recent versions of Pike.    *!    *! @example    *! @code    *! // This code was written for Pike 7.2, and depends on -  *! // the old behaviour for @[7.2::dirname()]. +  *! // the old behaviour for @expr{7.2::dirname()@}.    *! #pike 7.2    *!    *! // ... Code that uses @[dirname()] ...    *! @endcode    *!    *! This directive is also needed for Pike modules that    *! have been installed globally, and might be used by    *! a Pike that has been started with the @tt{-V@} flag.    *!    *! @example