pike.git / src / encode.c

version» Context lines:

pike.git/src/encode.c:18:   #include "pike_error.h"   #include "operators.h"   #include "builtin_functions.h"   #include "module_support.h"   #include "fsort.h"   #include "threads.h"   #include "stuff.h"   #include "version.h"   #include "bignum.h"    - RCSID("$Id: encode.c,v 1.100 2001/07/01 14:27:08 grubba Exp $"); + RCSID("$Id: encode.c,v 1.101 2001/07/01 16:59:45 grubba Exp $");      /* #define ENCODE_DEBUG */      #ifdef ENCODE_DEBUG   #define EDB(X) X   #else   #define EDB(X)   #endif      /* The sp macro conflicts with Solaris 2.5.1's <sys/conf.h>. */
pike.git/src/encode.c:2017:    decode_value2(data);    if ((Pike_sp[-1].type == T_INT) &&    (Pike_sp[-1].u.integer < PROG_DYNAMIC_ID_START) &&    (Pike_sp[-1].u.integer > 0)) {    struct program *p = id_to_program(Pike_sp[-1].u.integer);    if (!p) {    Pike_error("Failed to decode program %d\n",    Pike_sp[-1].u.integer);    }    pop_stack(); -  push_program(p); +  ref_push_program(p);    } else {    Pike_error("Failed to decode program.\n");    }    break;       default:    Pike_error("Cannot decode program encoding type %d\n",num);    }    break;