pike.git / src / encode.c

version» Context lines:

pike.git/src/encode.c:18:   #include "error.h"   #include "operators.h"   #include "builtin_functions.h"   #include "module_support.h"   #include "fsort.h"   #include "threads.h"   #include "stuff.h"   #include "version.h"   #include "bignum.h"    - RCSID("$Id: encode.c,v 1.61 2000/07/07 01:27:16 hubbe Exp $"); + RCSID("$Id: encode.c,v 1.62 2000/07/07 19:27:12 grubba Exp $");      /* #define ENCODE_DEBUG */      #ifdef ENCODE_DEBUG   #define EDB(X) X   #else   #define EDB(X)   #endif    -  + /* The sp macro conflicts with Solaris 2.5.1's <sys/conf.h>. */ + #ifdef sp + #undef sp + #define STACKPOINTER_WAS_DEFINED + #endif /* sp */ +    #ifdef _AIX   #include <net/nh.h>   #endif      #ifdef HAVE_NETINET_IN_H   #include <netinet/in.h>   #endif      #include <math.h>    -  + /* Restore the sp macro */ + #ifdef STACKPOINTER_WAS_DEFINED + #define sp Pike_sp + #undef STACK_POINTER_WAS_DEFINED + #endif /* STACKPOINTER_WAS_DEFINED */ +    #ifdef HAVE_FREXP   #define FREXP frexp   #else   double FREXP(double x, int *exp)   {    double ret;    *exp=(int)ceil(log(fabs(x))/log(2.0));    ret=(x*pow(2.0,(float)-*exp));    return ret;   }