pike.git / src / global.h

version» Context lines:

pike.git/src/global.h:604: Inside #if undefined(PMOD_EXPORT) and #if defined (__NT__) && defined (USE_DLL)
  #ifndef PMOD_EXPORT   # if defined (__NT__) && defined (USE_DLL)   # ifdef DYNAMIC_MODULE   # define PMOD_EXPORT __declspec(dllimport)   # else   /* A pmod export becomes an import in the dynamic module. This means    * that modules can't use PMOD_EXPORT for identifiers they export    * themselves, unless they are compiled statically. */   # define PMOD_EXPORT __declspec(dllexport)   # endif - # elif defined(__clang__) && defined(MAC_OS_X_VERSION_MIN_REQUIRED) + # elif defined(__clang__) && (defined(MAC_OS_X_VERSION_MIN_REQUIRED) || defined(__ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED__))   /* According to Clang source the protected behavior is ELF-specific and not    applicable to OS X. */   # define PMOD_EXPORT __attribute__ ((visibility("default")))   # elif __GNUC__ >= 4   # ifdef DYNAMIC_MODULE   # define PMOD_EXPORT __attribute__ ((visibility("default")))   # else   # define PMOD_EXPORT __attribute__ ((visibility("protected")))   # endif   # else