pike.git / src / interpret.c

version» Context lines:

pike.git/src/interpret.c:1:   /*   || This file is part of Pike. For copyright information see COPYRIGHT.   || Pike is distributed under GPL, LGPL and MPL. See the file COPYING   || for more information. - || $Id: interpret.c,v 1.285 2002/12/07 16:36:41 grubba Exp $ + || $Id: interpret.c,v 1.286 2003/01/05 19:54:04 grubba Exp $   */      #include "global.h" - RCSID("$Id: interpret.c,v 1.285 2002/12/07 16:36:41 grubba Exp $"); + RCSID("$Id: interpret.c,v 1.286 2003/01/05 19:54:04 grubba Exp $");   #include "interpret.h"   #include "object.h"   #include "program.h"   #include "svalue.h"   #include "array.h"   #include "mapping.h"   #include "pike_error.h"   #include "language.h"   #include "stralloc.h"   #include "constants.h"
pike.git/src/interpret.c:1358:       case APPLY_LOW:    o = (struct object *)arg1;    if(o->prog == pike_trampoline_program)    {    fun=((struct pike_trampoline *)(o->storage))->func;    scope=((struct pike_trampoline *)(o->storage))->frame;    o=scope->current_object;    goto apply_low_with_scope;    } -  fun = (ptrdiff_t)arg2; +  fun = ((char *)arg2) - (char *)0;       apply_low:   #undef SCOPE   #include "apply_low.h"    break;       apply_low_with_scope:   #define SCOPE scope   #include "apply_low.h"    break;