pike.git / src / modules / Gz / zlibmod.c

version» Context lines:

pike.git/src/modules/Gz/zlibmod.c:1:   /*   || This file is part of Pike. For copyright information see COPYRIGHT.   || Pike is distributed under GPL, LGPL and MPL. See the file COPYING   || for more information. - || $Id: zlibmod.c,v 1.78 2007/05/01 22:07:48 nilsson Exp $ + || $Id: zlibmod.c,v 1.79 2007/05/19 20:30:14 per Exp $   */      #include "global.h"   #include "zlib_machine.h"   #include "module.h"   #include "program.h"   #include "module_support.h"      #if !defined(HAVE_LIBZ) && !defined(HAVE_LIBGZ)   #undef HAVE_ZLIB_H
pike.git/src/modules/Gz/zlibmod.c:249:    switch(ret)    {    case Z_OK:    break;       case Z_VERSION_ERROR:    Pike_error("libz not compatible with zlib.h!!!\n");    break;       default: +  deflateEnd(&z.gz);    if(z.gz.msg)    Pike_error("Failed to initialize gz: %s\n", z.gz.msg);    else    Pike_error("Failed to initialize gz\n");    }       mt_init(&z.lock);       ret = do_deflate(buf, &z, Z_FINISH);   
pike.git/src/modules/Gz/zlibmod.c:583:    switch(ret)    {    case Z_OK:    break;       case Z_VERSION_ERROR:    Pike_error("libz not compatible with zlib.h!!!\n");    break;       default: +  inflateEnd( &z.gz );    if(z.gz.msg)    Pike_error("Failed to initialize gz: %s\n", z.gz.msg);    else    Pike_error("Failed to initialize gz\n");    }       mt_init(&z.lock);    ret = do_inflate(buf, &z, Z_SYNC_FLUSH);    mt_destroy(&z.lock); -  +  inflateEnd( &z.gz );       if(ret==Z_OK)    Pike_error("Compressed data is truncated.\n");    if(ret!=Z_STREAM_END)    Pike_error("Failed to inflate data (%d).\n", ret);   }      /*! @decl string uncompress(string data, void|int(0..1) raw)    */   static void gz_uncompress(INT32 args)