pike.git / src / modules / Mysql / configure.in

version» Context lines:

pike.git/src/modules/Mysql/configure.in:1:   # - # $Id: configure.in,v 1.49 2006/07/01 23:53:19 mast Exp $ + # $Id: configure.in,v 1.50 2006/07/04 20:45:27 mast Exp $   #   # Configure script for the mysql-module   #   # Henrik Grubbström   #      #   # NOTE:   # Prior to 3.20.0 After 3.20.0   # -------------------------------------------------------------------
pike.git/src/modules/Mysql/configure.in:191:    fi    if echo $LIBS|grep -- -lm >&5 2>&5; then    :    else    AC_CHECK_LIB(m, floor, [    LIBS="-lm $LIBS"    MYSQL_LIBS="-lm ${MYSQL_LIBS}"    ], [])    fi    +  # Header check necessary for PIKE_FUNCS_NEED_DECLS. +  AC_CHECK_HEADERS(pthread.h) +     # Pthreads is still needed in 3.20.0.    AC_CHECK_FUNC(pthread_self, [], [    AC_CHECK_LIB(pthread, pthread_self, [    LIBS="-lpthread $LIBS"    echo Warning added -lpthread to \$LIBS\!    ], [    AC_CHECK_LIB(pthreads, pthread_self, [    LIBS="-lpthreads $LIBS"    echo Warning added -lpthreads to \$LIBS\!    ], [])