pike.git / src / modules / Mysql / configure.in

version» Context lines:

pike.git/src/modules/Mysql/configure.in:1:   # - # $Id: configure.in,v 1.1 1997/02/11 08:36:34 hubbe Exp $ + # $Id: configure.in,v 1.2 1997/04/03 18:07:16 grubba Exp $   #   # Configure script for the mysql-module   #   # Henrik Grubbström   #      #   # NOTE:   # Prior to 3.20.0 After 3.20.0   # --------------------------------------------------------------
pike.git/src/modules/Mysql/configure.in:68:    echo Adding $pike_cv_mysql_include_dir to the include search path.    CPPFLAGS="-I$pike_cv_mysql_include_dir ${CPPFLAGS}"    fi       # Header file       AC_CHECK_HEADERS(mysql.h mysql/mysql.h)       # Mysql libs    -  pike_cv_mysql="no" +  pike_cv_mysql="unknown"       AC_CHECK_LIB(mystrings, bchange, [    LIBS="-lmystrings $LIBS"    MYSQL_LIBS="-lmystrings ${MYSQL_LIBS}"    pike_cv_mysql="post3.20"    ], [    AC_CHECK_LIB(strings, bchange, [    LIBS="-lstrings $LIBS"    MYSQL_LIBS="-lstrings ${MYSQL_LIBS}"    pike_cv_mysql="pre3.20"    ], [])    ])       AC_MSG_CHECKING(Mysql version)       AC_MSG_RESULT($pike_cv_mysql)    -  if test x$pike_cv_mysql = xno; then -  # Restore variables, so we don't link with unnessesary libs -  -  LIBS=$OLD_LIBS -  CPPFLAGS=$OLD_CPPFLAGS -  LDFLAGS=$OLD_LDFLAGS -  MYSQL_LIBS="" -  else -  +     # System libs which might be needed       if echo $LIBS|grep -- -lsocket >&5 2>&5; then    :    else    AC_CHECK_LIB(socket, socket, [    LIBS="-lsocket $LIBS"    MYSQL_LIBS="-lsocket ${MYSQL_LIBS}"    ], [])    fi
pike.git/src/modules/Mysql/configure.in:175:       LIBS=$OLD_LIBS    CPPFLAGS=$OLD_CPPFLAGS    LDFLAGS=$OLD_LDFLAGS    MYSQL_LIBS=""    else    AC_DEFINE(HAVE_MYSQL)       AC_CHECK_FUNCS(mysql_real_query mysql_fetch_lengths)    fi -  fi +    else    :   fi      AC_SUBST(MYSQL_LIBS)      AC_OUTPUT(Makefile,echo FOO >stamp-h )