pike.git / src / modules / Mysql / configure.in

version» Context lines:

pike.git/src/modules/Mysql/configure.in:1:   # - # $Id: configure.in,v 1.15 2000/03/22 23:41:12 grubba Exp $ + # $Id: configure.in,v 1.16 2000/08/23 17:57:53 grubba Exp $   #   # Configure script for the mysql-module   #   # Henrik Grubbstrm   #      #   # NOTE:   # Prior to 3.20.0 After 3.20.0   # --------------------------------------------------------------
pike.git/src/modules/Mysql/configure.in:147:    AC_CHECK_LIB(dbug, _db_doprnt_, [    LIBS="-ldbug $LIBS"    MYSQL_LIBS="-ldbug ${MYSQL_LIBS}"    ], [])       AC_CHECK_LIB(mysys, my_init, [    LIBS="-lmysys $LIBS"    MYSQL_LIBS="-lmysys ${MYSQL_LIBS}"    ], [])    +  # mysql 3.23.x libmysqlclient requires zlib... +  AC_CHECK_LIB(z, compress, [ +  LIBS="-lz $LIBS" +  MYSQL_LIBS="-lz ${MYSQL_LIBS}" +  ], []) +     # Try a couple of mysqlclient libs    # in order of age, newest first.      define([AC_CHECK_SQLLIB],   [   AC_MSG_CHECKING(for mysql_connect in $1)   AC_CACHE_VAL(ac_cv_pike_lib_$1_mysql_connect,   [    ac_save_LIBS="$LIBS"   LIBS="-l$1 $LIBS"