pike.git / src / modules / Ssleay / configure.in

version» Context lines:

pike.git/src/modules/Ssleay/configure.in:1: - # $Id: configure.in,v 1.5 1998/09/20 08:32:36 hubbe Exp $ + # $Id: configure.in,v 1.6 2001/02/14 21:20:41 mirar Exp $   AC_INIT(ssleay.c)      AC_CONFIG_HEADER(config.h)      AC_MODULE_INIT()      AC_ARG_WITH(ssleay, [ --with-ssleay enable the ssleay-module],[],[with_ssleay=no])    -  + PIKE_FEATURE_WITHOUT(Ssleay) +    if test x$with_ssleay = xyes; then -  +  PIKE_FEATURE_NODEP(Ssleay) +     OLD_LDFLAGS=$LDFLAGS    OLD_CPPFLAGS=$CPPFLAGS    OLD_LIBS=$LIBS       AC_MSG_CHECKING(Checking for existance of SSLeay)       AC_CACHE_VAL(pike_cv_ssleay_exists,    [    if test -d /usr/local/ssl ; then    pike_cv_ssleay_exists="yes"
pike.git/src/modules/Ssleay/configure.in:44:       AC_CHECK_LIB(crypto, ERR_print_errors_fp, [], [ pike_cv_ssleay="no" ])    AC_CHECK_LIB(ssl, SSL_use_PrivateKey_file, [], [ pike_cv_ssleay="no" ])       AC_MSG_CHECKING(Supported version of SSLeay)       AC_MSG_RESULT($pike_cv_ssleay)       if test x$pike_cv_ssleay = xyes; then    AC_DEFINE(HAVE_SSLEAY) +  PIKE_FEATURE_OK(Ssleay)    else    # Restore variables, so we don't link with unnessesary libs       LIBS=$OLD_LIBS    CPPFLAGS=$OLD_CPPFLAGS    LDFLAGS=$OLD_LDFLAGS    fi    fi   fi      AC_OUTPUT(Makefile,echo FOO >stamp-h )