pike.git / src / modules / system / configure.in

version» Context lines:

pike.git/src/modules/system/configure.in:4:   AC_MODULE_INIT(_system)      AC_CHECK_LIB(bind, __inet_ntoa)   AC_CHECK_LIB(socket, socket)   AC_CHECK_LIB(nsl, gethostbyname)   AC_CHECK_LIB(net, __get_socket_descriptor)      dnl For Cygwin   AC_CHECK_LIB(cygipc, shmget)    - PIKE_AC_CHECK_OS() -  +    if test x"$pike_cv_sys_os" = xWindows_NT ; then    # FIXME: These look suspiciously much like 32bit versions.    # We probably want to use 64bit versions on IA64.    LIBS="-lshell32 -lkernel32 -lws2_32 -ladvapi32 -lole32 $LIBS"   fi      AC_CHECK_HEADERS(syslog.h sys/syslog.h sys/types.h errno.h unistd.h pwd.h \    sys/socket.h netinet/in.h arpa/inet.h netdb.h stdarg.h winsock2.h \    sys/utsname.h pwd.h passwd.h shadow.h grp.h sys/stat.h winsock.h \    sys/systeminfo.h windows.h sys/param.h utime.h sys/utime.h sys/id.h \