pike.git / src / pike_embed.c

version» Context lines:

pike.git/src/pike_embed.c:3:   || Pike is distributed under GPL, LGPL and MPL. See the file COPYING   || for more information.   */      /*    * Pike embedding API.    *    * Henrik Grubbström 2004-12-27    */    - #include "global.h" + #include "module.h"   #include "fdlib.h"   #include "backend.h" - #include "module.h" - #include "object.h" +    #include "lex.h"   #include "pike_types.h"   #include "builtin_functions.h" - #include "array.h" - #include "stralloc.h" +    #include "interpret.h"   #include "pike_error.h"   #include "pike_macros.h"   #include "callback.h"   #include "signal_handler.h"   #include "threads.h"   #include "dynamic_load.h"   #include "gc.h" - #include "multiset.h" - #include "mapping.h" +    #include "cpp.h"   #include "main.h"   #include "operators.h"   #include "rbtree.h"   #include "constants.h"   #include "version.h" - #include "program.h" +    #include "pike_rusage.h"   #include "module_support.h"   #include "opcodes.h" - #include "pike_memory.h" +    #include "pike_cpulib.h"   #include "pike_embed.h"   #include "pike_modules.h"      #if defined(__linux__) && defined(HAVE_DLOPEN) && defined(HAVE_DLFCN_H)   #include <dlfcn.h>   #endif      #include "las.h"