pike.git / src / post_modules / Nettle / configure.in

version» Context lines:

pike.git/src/post_modules/Nettle/configure.in:60:    "x$ac_cv_lib_nettle_md5_init" = "xyes"; then    PIKE_FEATURE_OK(Nettle)       # md4 is available in Nettle 1.8 and later.    # arctwo is available in Nettle 1.11 and later.    # ctr is available in Nettle 1.13 and later.    # camellia is available in Nettle 2.1 and later.    # gcm is available in Nettle 2.2 and later.    # ripemd160 is available in Nettle 2.3 and later.    # sha3 and gosthash94 is available in Nettle 2.6 and later. +  # dsa-compat.h is to detect the new DSA API in Nettle 3.0 and later.    AC_CHECK_HEADERS(nettle/camellia.h nettle/md4.h nettle/sha3.h \    nettle/arctwo.h nettle/ripemd160.h nettle/gosthash94.h \ -  nettle/ctr.h nettle/gcm.h nettle/ecdsa.h) +  nettle/ctr.h nettle/gcm.h nettle/ecdsa.h \ +  nettle/dsa-compat.h)    AC_CHECK_FUNCS(nettle_md4_init)       AC_MSG_CHECKING([for idea.c])    # Have the patent-encumbered idea files been purged?    if test -f "$srcdir/idea.c" ; then    AC_MSG_RESULT([found])    AC_DEFINE([WITH_IDEA], 1, [idea.c available])    IDEA_OBJ=idea.o    else    AC_MSG_RESULT([no])    IDEA_OBJ=""    fi    -  # These might have been purged from the Nettle lib to avoid GPL +  # These may have been purged from the Nettle lib to avoid GPL    # contamination.    AC_CHECK_FUNCS(nettle_blowfish_decrypt nettle_serpent_decrypt)       # This is the recomended interface in Nettle 2.0.    AC_CHECK_FUNCS(nettle_yarrow256_slow_reseed)    -  # This wasn't present in old Nettles. +  # These weren't present in old Nettles.    AC_CHECK_FUNCS(nettle_salsa20_crypt nettle_sha224_init)       AC_MSG_CHECKING([for struct yarrow256_ctx.seed_file])    AC_CACHE_VAL(pike_cv_nettle_struct_yarrow256_ctx_seed_file, [    pike_cv_nettle_struct_yarrow256_ctx_seed_file=no    AC_TRY_COMPILE([   #include <nettle/yarrow.h>    ], [    struct yarrow256_ctx ctx;    return !sizeof(ctx.seed_file);