pike.git / src / post_modules / Nettle / hogweed.cmod

version» Context lines:

pike.git/src/post_modules/Nettle/hogweed.cmod:400:    THIS->curve = nettle_get_secp_224r1();    break;   #endif /* HAVE_CURVE_NETTLE_SECP_224R1 */   #ifdef HAVE_CURVE_NETTLE_SECP_256R1    case 256:    THIS->curve = nettle_get_secp_256r1();    break;   #endif /* HAVE_CURVE_NETTLE_SECP_256R1 */   #ifdef HAVE_CURVE_NETTLE_SECP_384R1    case 384: -  THIS->curve = nettle_get_secp_384r1; +  THIS->curve = nettle_get_secp_384r1();    break;   #endif /* HAVE_CURVE_NETTLE_SECP_384R1 */   #ifdef HAVE_CURVE_NETTLE_SECP_521R1    case 521:    THIS->curve = nettle_get_secp_521r1();    break;   #endif /* HAVE_CURVE_NETTLE_SECP_521R1 */    default:    Pike_error("Invalid curve\n");    break;