pike.git / src / post_modules / Nettle / hogweed.cmod

version» Context lines:

pike.git/src/post_modules/Nettle/hogweed.cmod:998:   #endif /* HAVE_NETTLE_ECDSA_H */      /*! @endmodule Nettle    */      void   hogweed_init(void)   {    INIT;    + #ifdef HAVE_NETTLE_ECDSA_H    ADD_INT_CONSTANT("SECP192R1", SECP192R1, 0);    ADD_INT_CONSTANT("SECP224R1", SECP224R1, 0);    ADD_INT_CONSTANT("SECP256R1", SECP256R1, 0);    ADD_INT_CONSTANT("SECP384R1", SECP384R1, 0);    ADD_INT_CONSTANT("SECP521R1", SECP521R1, 0); -  + #endif /* HAVE_NETTLE_ECDSA_H */   }      void   hogweed_exit(void)   {    EXIT;   }      #endif