pike.git / src / post_modules / Nettle / nettle.cmod

version» Context lines:

pike.git/src/post_modules/Nettle/nettle.cmod:1:   /* nettle.cmod -*- c -*- */      #include "global.h" - RCSID("$Id: nettle.cmod,v 1.13 2003/08/06 09:59:24 grubba Exp $"); + RCSID("$Id: nettle.cmod,v 1.14 2003/08/06 10:00:33 grubba Exp $");   #include "interpret.h"   #include "svalue.h"   /* For this_object() */   #include "object.h"   #include "module_support.h"      #include "nettle_config.h"      #ifdef HAVE_LIBNETTLE    - #include <nettle/yarrow.h> +    #include "nettle.h"    -  + #include <nettle/yarrow.h> +    #include <assert.h>   #include <stdio.h>   #include <stdarg.h>      DECLARATIONS      /*! @module Nettle    *! Low level crypto functions used by the @[Crypto] module. Unless    *! you are doing something very special, you would want to use the    *! Crypto module instead.